Back to overview
Degraded

Some customers are unable to review check batches.

Oct 07 at 09:24am EDT
Affected services
Aptexx Web Application

Resolved
Oct 07 at 01:16pm EDT

The issue has been resolved. Thank you for your patience!

Updated
Oct 07 at 09:53am EDT

We have identified the root cause of the issue and are working to address it as quickly as possible.

Created
Oct 07 at 09:24am EDT

Some customers are unable to review check batches. We’re aware of the issue and are working on it urgently.

We’re sorry to be holding you up today! Please know our teams are working hard to get everything up and running, and we will update you in as soon as possible with the latest information. support@aptexx.com