Customers are experiencing issues reviewing check batches.
Resolved
Sep 30 at 12:45pm EDT
We have confirmed the root cause of the issue. Thank you so much for your patience with us!
Affected services
Updated
Sep 30 at 11:57am EDT
We will be making some changes to our systems to address this issue. End users may be temporarily blocked from the system for less than 2 minutes.
Affected services
Created
Sep 30 at 11:37am EDT
Some customers are unable to review check batches. We’re aware of the issue and are working on it urgently.
We’re sorry to be holding you up today! Please know our teams are working hard to get everything up and running, and we will update you in as soon as possible with the latest information. support@aptexx.com
Affected services