Service Outage Notification – Due Date and Balance Display Issues
Resolved
Aug 22 at 06:50pm EDT
Issue is fixed
Affected services
Updated
Aug 22 at 05:17pm EDT
We have identified the root cause of the issue and a fix will be deployed at 6:30 PM ET. Thank you for your patience!
Affected services
Created
Aug 22 at 02:25pm EDT
We are currently experiencing a system outage that is affecting some integrations across our platform. As a result, payer-facing balances and due dates may be displayed incorrectly in some instances.
Our engineering team is actively investigating the issue and working to restore full functionality as quickly as possible. We understand the importance of accurate information and apologize for any confusion or inconvenience this may cause.
What you need to know:
Payers may see incorrect balances and due dates.
We will provide updates as soon as more information is available.
We appreciate your patience and understanding. If you have any questions or need assistance in the meantime, please don’t hesitate to reach out to our support team.
Affected services